VSCode Setup on MacOS Catalina

Thanks to the Onethinx Team,

I was able to set up the complete VSCode on MacOS and there are no issues.
Screenshot attached:


The build completed successfully for the Hello World program.

However while debugging, the module doesn’t Join the gateway and after a long time the blue LED blinks forever.

The Gateway works fine with other modules too.

Also, though everything works fine, I would like to highlight few errors/info messages I came across:

  1. Though these include errors appear, the build happens successfully.

@Rolf or @Tom - Can anyone help me in solving this issue?

PS: I tried a blink program which doesn’t involve connecting to LoRa and that works smooth. The Blue LED blinks as per the interval set.

Thanks

Hi Sree,

Are the keys you entered correct?

Make sure your version of the module corresponds with the API you use according this list.

Also make sure the coreConfiguration is pointing to the right keys and configured correctly (look at the corresponding API documentation).

I’ve noticed issues with the TTN network as well, not being able to join at certain moments.

How to check the version of the module which I’m using. The API doesn’t give a clue of it. I can see different versions are available.

The keys are entered correctly.

I’m trying now again, will update you shortly.

Regards,
Sri

@Rolf

I was able to successfully get the stack version.

Screenshot 2020-01-04 at 3.35.30 PM
So, probably this might be the API Version: 0x000000B0

I proceeded with the next steps after using the B0 API. These are what the errors I am getting.

Errors:

Problems:

Can you help?

Did you do a clean reconfigure? (which is needed after file/folder structure changes).

Yes, I have done that.

Screenshot for reference.

Can you change these lines in CMakeLists.txt (somewhere around line 100) and show me the output of the Clean Reconfigure?

message("Source include dirs:" ${SOURCE_INCLUDE_DIRS})
# Find Source files (containing *.c)
FILE(GLOB_RECURSE SOURCE_SRCS ${SOURCE_DIR}/*.c)
FILE(GLOB_RECURSE DESIGN_SRCS ${DESIGN_DIR}/GeneratedSource/*.c)
message("Source dirs:" ${SOURCE_SRCS})
message("Design source dirs:" ${DESIGN_SRCS})

Complete Path Details:

[cmake] Chip variant: CY8C6347BZI_BLD53

[cmake] Configuring done

The path Users/srikapardhi/Documents/onethinx/VSCodeHelloWorld-master/source/OnethinxCore seems to be okay.

I notice you’re using an odd compiler /usr/local/bin/arm-none-eabi-gcc. Which kit did you select?

Please find the information below:
make and arm versions:

Kits: I tried selecting both the kits, and the result is same.

thanks.

Is /usr/local/bin/arm-none-eabi-gcc a link to the 9.2.1 compiler?

Could you add this to you local cmake-tools-kits.json file (command palette >> edit local cmake kits):

  {
    "name": "GCC for ARM",
    "compilers": {
      "C": "arm-none-eabi-gcc",
      "CXX": "arm-none-eabi-g++"
    },
    "keep": true
  },

And then force the compiler at settings.json using:

"cmake.configureEnvironment": {"PATH": "${env:PATH}:/yourpath/9-2019-q4-major/bin"},
"cmake.environment": {"PATH": "${env:PATH}:/yourpath/9-2019-q4-major/bin"},
"cortex-debug.armToolchainPath": "/yourpath/9-2019-q4-major/bin"

Is /usr/local/bin/arm-none-eabi-gcc a link to the 9.2.1 compiler?

Looks like yes.

Could you add this to you local cmake-tools-kits.json file (command palette >> edit local cmake kits):
Done:

And then force the compiler at settings.json using:
Done:

Clean Reconfigure:

Clean Rebuild:

I see no change in errors and the compiler looks like is the same one earlier.

I go to the basics, is the API the right one which I am using?

Yes. And oops, now I notice version 0xB0 doesn’t support LoRaWAN_GetInfo.

Seems you are all okay but your stack version doesn’t support the call. I’m sorry for the confusion.

You can safely comment out the LoRaWAN_GetInfo call.

@Rolf I commented the LoRaWAN_GetInfo function and the build finished successfully just like how it used to happen earlier.

Screenshot:

Strangely, the module is yet to get connected over the TTN.

I would try the complete process again, may be by creating a new device on TTN and give you an update.