vsCode setup check question

I’ve been following the ‘PSoc6 Dual Core Project for VS code’ instructions from Github and in section 4, Check I find make is not found but mingw32-make is - do I need to fix this or am I set to try a project?

PS C:\Users\Halam> make -v
make : The term ‘make’ is not recognized as the name of a cmdlet, function, script
file, or operable program. Check the spelling of the name, or if a path was included,
verify that the path is correct and try again.
At line:1 char:1

  • make -v
  •   + CategoryInfo          : ObjectNotFound: (make:String) [], CommandNotFoundExcepti  
      + FullyQualifiedErrorId : CommandNotFoundException

PS C:\Users\Halam> mingw32-make.exe -v
GNU Make 3.82.90
Built for i686-pc-mingw32
Copyright © 1988-2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
PS C:\Users\Halam>

Something odd with the result I pasted in, here is a screen shot. Oh I forgot to mention, the video ha smore steps than the document, which is up to date?

Hi Halam,

The most actual and updated version is here.
Please see the guide for setting up VS code at the end of the read-me.

As you have our module, the CM0+ is locked so you better not use the dual-core project.

The video is more-less outdated. The instructions above are most accurate.

Also, as you’re installed mingw32-make (mingw32-make.exe -v is responding), you’re good to go!

Hi Rolf,
When I clean I get errors needing cmake path - which I have fixed and:
Unable to determine what CMake generator to use. Please install or configure a preferred generator, or update settings.json, your Kit configuration or PATH variable.

I have verified that cmake tools is installed, but from what I have read VScode is the generator - so where do I point cmake generator path please?

Hi Hallam,

Did you install CMake as well?


And make sure you enter the path in the je settings.


Hi Rolf,
I’m starting to feel like we are old friends :slight_smile:
I have cmake installed:

C:\Users\Halam>cmake -v
CMake Error: The source directory “C:/Users/Halam/-v” does not exist.
Specify --help for usage, or press the help button on the CMake GUI.

Is cmake itself the cmake generator? I’m not sure I understand but I thought the generator was the thing that configures cmake for a project, that would be VScode?

Ah, maybe it’s a problem with minGW, I copied the files which from the instructions seemed to be an alternative to running the installer. I’ll check that path.

If I’m right, and the cmake generator should be minGW, then which do I path to:

You are entitled to time off over Christmas so dont feel pressured to answer my questions at the weekend.

There are two different programs: CMake and Make.

CMake is able to build complex makefiles which are needed for the make (build) procedure. You should install CMake as well as make (you can use the files in the VScode dual core file and add the bin folder to your path).

Next you should update your settings json file (view >> command palette, type: “settings.json” and add your path:

"cmake.cmakePath": "C:/Program Files/CMake/bin/cmake.exe",

Thanks, but I like to get you up and running. Hope you will with my information above ^^

Thank you Rolf for sticking wiht it.
I had some bad cmake errors which were because of a typing error. I no longer get bad cmake error so I know cmake path is right.
Now I have

and get

I need to go do other stuff tonight so no need to reply right away.

Did you install the GNU ARM Toolkit? Does it run from terminal (arm-none-eabi-gcc -v)?

Go to: Command Palette, type kits
Scan for kits and see if the extension finds the GNU ARM toolkit.

If not add the compiler manually: Edit User-Local CMake kits

   "name": "GCC for arm-none-eabi 8.2.1",
   "compilers": {
     "C": "/Applications/gcc-arm-none-eabi-8-2018-q4-major/bin/arm-none-eabi-gcc-8.2.1"

Make sure you correct the above path for you installation.

Hi Rolf, happy Sunday.

Does this look right? I’m puzzled by the repetition:

Hi Halam,

The kit is found at least (arm-none-eabi 9.2.1). Does reconfigure / rebuild work?

Hi Rolf,
I get

Executing task: C:\Users\Halam\Documents\VSCodeHelloWorld-master/config/scripts/check_build.bat VSCodeHelloWorld-master <

mingw32-make: CMakeFiles/VSCodeHelloWorld-master.elf.dir/build.make: No such file or directory
mingw32-make: *** No rule to make target ‘CMakeFiles/VSCodeHelloWorld-master.elf.dir/build.make’. Stop.
**** Please fix build errors. ****
The terminal process terminated with exit code: 1

And I dont have any files in my cmake project outline. Where should those come from?

Hi Halam,

Is there a file check_build.bat in your C:\Users\Halam\Documents\VSCodeHelloWorld-master/config/scripts/ folder?

If not, try downloading from our github. We made some changes to that recently.

Hi Rolf,
Happy new year.
I do have check_build.bat
Could I take you up on your offer of a remote desktop session to help get me unstuck?
Thanks and happy new year

Hi Halam, happy new year as well.

Sure, let me know whenever it suits you.