Tried the new Onethinx Core dependencies pack for linux

I tried the Onethinx Core dependencies pack for linux (https://github.com/onethinx/VSCode_OnethinxPack_Linux) together with the minimalistic Hello World example (https://github.com/onethinx/VSCode_HelloWorld)

I hit a few bumps on the road:

  • CMakeLists.txt refers to CyMcuElfTool, but on a case sensitive system like linux that should have been cymcuelftool
  • I had to scratch my CMake kits file to get cmake to recognize the new compiler location rm ~/.local/share/CMakeTools/cmake-tools-kits.json
  • When I fired up the Device Configurator I hit the error shown in the screen shot below. Had to navigate to where I had installed the dependency pack

image

  • It appears that the CLK_PERI is actually 8MHz even if the Device Configurator thinks it is 16MHz, resulting in some strange data rates. I changed CLK_PERI divider from 2 to 4 to get that right. Not sure I fully understand this.

Found one more issue with the Device Configurtor - when trying to configure an SBC for I2C

Seems your extracts from ModusToolbox is missing a few pieces

Thanks!

Fixed the JRE folder, the cymcuelftool and the design configuration.

Actually, in the latest version of the stack, CLK_PERI comes from the IMO_CLK through Path 0 (8MHz, no divider):
image

For the cmake-tools-kits.json View >> Command Pallete >> CMake: Scan for Kits should work instead of scratching the cmake-tools-kits.json. Will update the documentation.

Thanks a lot for your help, much appreciated!